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Easylon Analyzer – User Manual 

Preliminary Remark 

This User Manual to the Easylon® Analyzer wants to be the user’s guide to an effective work 
with this Easylon product. 

Note:  The current version of the Easylon Analyzer software is compatible with the old Easylon 
Analyzer Boxes as well as with Easylon VNI interfaces. The Analyzer Box is described in this 
document. Please refer to the separate documentation of the specific VNI interface is you are 
going to use this for network access. 

Proceeding on the assumption that the user has excellent knowledge and experience in using 
Echelon’s® LONWORKS® technology, this manual will not go into detail as far as terms and 
concepts of this field are concerned. We also assume that the use of Microsoft Windows™ 
and the general rules of operation of programs working with this user surface are known.  

The documentation is divided into the main parts 

Introduction background of Analyzer operation 

Getting Started describes the installation 

Tutorial tour through the use of the Analyzer 

Troubleshooting Guide helps you with some frequently occurring 
problems 

Reference Manual informs about Analyzer hardware and all 
commands 

Appended are a glossary and an index.  

 

This documentation is subject to changes without notice. Gesytec assumes no responsibility 
or liability for any errors or inaccuracies that may appear in this document.  

Gesytec shall have no liability or responsibility to the original purchaser or any other person 
or entity with respect to any claim, loss, liability or damage caused or alleged to be caused 
directly or indirectly by any Gesytec software or the accompanying documentation.  
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1 Introduction 

1.1 Background of Operation 

The power of a local operating network lies in its distributed nature: each network node is an 
autonomous entity and can perform its tasks independently. But of course, the whole idea of 
using a network of nodes already indicates that these autonomous nodes with their "intelli-
gent" NEURON® Chips become effective only when exchanging data. A valve controller 
needs input from various sensors in order to calculate the necessary adjustments. In 
Echelon’s® LONWORKS® technology communication is done through a bus system, the local 
operating network, which can be divided into a number of logical "domains" and consist of 
several physical segments in which the actual data transport may be handled by any available 
media. Communication is governed by Echelon’s LonTalk® protocol, which is implemented 
on the NEURON Chips.  

Communication between the NEURON Chips is what makes the network operate. Commu-
nication is also the key to network maintenance: by monitoring the messages being sent 
around the network you can find out whether requests are answered correctly or whether cer-
tain nodes are not responding as they should. But the possibility of listening in on the on-
going communication in the local operating network is restricted: each NEURON Chip can 
only “hear” messages which are addressed to it, either explicitly or implicitly (if the NEURON 
Chip is part of an addressed group). This is where Gesytec's Easylon® Analyzer comes to the 
rescue … 
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1.2 Easylon Analyzer Overview 

The Easylon Analyzer allows “eavesdropping” on whatever goes on in the local operating 
network; all communication on the network can be monitored from a PC running Windows. 
But the Easylon Analyzer does more: it can make use of the unique self-documentation fea-
ture of the LONWORKS technology to build an intelligible map of the network. Also, the 
consistency of the network can be checked (detection of multiple nodes with the same logical 
address, detection of unbound network variables). 

The following picture gives an overview of the setup of the Easylon Analyzer in case it is 
operated with a special hardware– the Analyzer Box. The Analyzer Box consists of two main 
parts: the network node part with the NEURON Chip is active, acting like a normal node 
included the network and requesting specific information from other nodes. This is the part 
that generates the requests during network scans or browsing of network variables. The 
recorder part is passive, acting as a spy, by listening in on all communication on the network 
segment to which the Analyzer Box is connected. This is the part that reads packets into the 
packet buffer of the Analyzer, subsequently to be transferred to the PC for investigation by 
the user with the Analyzer program.  

buffer
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LonWorks network

PC

Easylon Analyzer Box

Easylon Analyzer  
program windows

files

co
m
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Figure 1: Easylon Analyzer Box and program in the network 

The combination of the active network node part and the passive recorder part give the 
Easylon Analyzer its power of investigating nodes by communication helping the operator to 
install and maintain local operating networks easily. To help the user of the Easylon Analyzer 
in understanding on which levels the various commands of the Easylon Analyzer program 
take effect, the following conceptual levels can be identified: 
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Level 0: The NEURON Chip 

Inside the node’s NEURON Chip the network variables (NVs) are stored. NVs on other nodes 
are accessible through the Analyzer’s NEURON Chip, which can generate the appropriate 
messages to investigate the status of network variables. This is the level at which the Ana-
lyzer’s NV Browser works: it shows the internal status of individual NEURON Chips and their 
NVs in the network. 

Level 1: The network interconnections 

The nodes are connected in cooperating network. Cooperation between nodes is implemented 
on the basis of messages. The lowest unit in a network is a single, individually addressable 
node. The nodes are interconnected by a physical network which may consist of several 
“segments” of even different media. From another point of view –the communication view– 
the network is divided into logical “domains” with “subnets” and unique nodes in the sub-
nets. Furthermore nodes can be part of “groups”, which are defined in the context of the 
application. Messages are addressed to individual nodes and groups or broadcasted to subnets 
or entire domains. The Easylon Analyzer can thus request all nodes belonging to the domain 
to which it is set. 

Level 2: The Easylon Analyzer’s recorder and packet buffer 

Apart from a regular network node, which can generate messages to other nodes (e.g. to in-
vestigate the status of NVs) and receive reply messages which are addressed to it, the Easylon 
Analyzer contains a spying device, which can copy all messages being sent on the connected 
physical segment of the network to a “packet buffer”. At this level the recording capabilities 
of the Easylon Analyzer work. This is also the level where filters are defined and set: using a 
filter causes a selection of messages to be recorded, others to be ignored. 

Level 3: The Analyzer program window 

With the Analyzer software and the interconnection of the Analyzer to the PC, packets 
stored in the packet buffer of the Analyzer can be read into the active “Packets window”. In a 
separate window, the “Nodes Window”, information about NEURON Chips can be displayed, 
which is uploaded from the nodes in the domain to which the Analyzer is set. At this level, 
the various information is made visible to the Analyzer user. The “Get” commands link this 
level to the previous one. 

Level 4: The PC’s file system 

Finally, data which has been read from the Analyzer —either recorded in the packet buffer or 
directly requested in a network scan and uploaded subsequently— and displayed in an 
Analyzer program window can be stored in a file. Information stored in a file can be used in 
future sessions, e.g. when checking the current status of the network in comparison to a pre-
viously saved network description. 
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1.3 Network Interface 

Additionally to the „Analyzer“ function the Easylon Analyzer Box ca be used as a network 
interface. Installation of the appropriate software is described in the chapter „2.4 Network 
Interface Driver Installation“. 
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2 Getting Started 

2.1 Requirements 

• PC running Microsoft Windows 2000 or later versions. 

• The Easylon Analyzer program  

• Analyzer Box or Easylon VNI Interface 

2.2 Installing the Hardware 

This chapter describes the steps necessary to set up the Analyzer Box. For use of Easylon VNI 
interfaces refer to the respective manuals.  

Connection to the network  

 Connect the Easylon Analyzer Box to the network segment you want to analyze. A 
connector plug for screw & plug front connector (fig. 2/3) is contained in the delivery. 

Attention Make sure that interface type and baud rate of the Analyzer comply with the type and baud 
rate of your network. Check with the information given on the type label on the rear side. 

 

Figure 2: The Easylon Analyzer hardware: Analyzer front panel 
1 “Stat” LED: status indicator 
2 LON LED: Network traffic  
3 LonWorks network connector (3-pin plug & screw connector) 
4 RS232 connector (9-pin D type) 
5 Power-in connector  
6/7 “Service” button and “Service” LED for the Analyzer’s NEURON Chip 
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 Connect the Analyzer Box to the power supply you received with your Analyzer (fig. 
2/5). The “Stat” LED (fig. 2/1) on the Analyzer’s front panel will be blinking after 
communication with the PC has been established. 

Connection to the PC 

 Use the cable with the 9-pin D-type connectors on either side to attach the analyzer 
box (fig. 2/4) to the PC’s serial port.  

Attention You have to make sure that this serial port is the same as indicated in the “LNA.INI” file 
which you have to copy from the Easylon Analyzer installation disk to your windows envi-
ronment, since the software connects to that port (cf. Installing the Software).  

Electromagnetic Compatibility 

The Analyzer is a CE certified product and meets the intent of Directive 89/336/EEC for Elec-
tromagnetic Compatibility and amendment 93/31/EEC.  

To ensure electromagnetic compatibility in accordance with Directive 
89/336/EEC for operation of the Analyzer the ferrite cores enclosed in the 
delivery have to be mounted around the LONWORKS and RS232 connec-
tion cables and around the power supply cable.  

 

Please put the ferrite core around the cable close to the connector on the 
analyzer box end side. The distance between the ferrite core and the con-
nector on the Analyzer face plate must not exceed 10 cm. Ensure, if 
necessary, that it will stay in place.  

Mount ferrite core close to con-
nector 
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2.3 Installing the Software 

NOTE: License key required. 
If you are not using the Easylon Analyzer Box, the  software is running in a demo mode as 
long as no license key is applied. In this mode every third packet is suppressed, all other 
functions can be used without restriction.  
The license key is dependent on the Neuron ID of the network interface you are using the 
connect to the LonWorks network.   
To enter the code start the Analyzer software, select “option” from the “analyzer” menu and 
enter the key code.   
Be careful to use a matching Neuron ID and key code! 

 

To install the software start the setup from the Easylon Analyzer installation CD. This will 
install the Analyzer program on your hard disk.  

The Analyzer program can be stored to any directory. You will be prompted to accept the 
default C:/Analyzer directory or indicate a different one. 

Along with the Analyzer program the „Network Interface Driver“ will be installed (see next 
page). 

LNA.INI 

This file holds some initializing data for the Analyzer program; it also indicates to the Ana-
lyzer program which serial port of the PC is to be used to communicate with the Analyzer 
hardware. For different operating systems the settings in the LNA.INI file have to be modi-
fied according to the table below. 

Attention It is important, that the Analyzer program can find the LNA.INI file and the communication 
port entry in it. If this assignment can’t be found, the Analyzer program will use COM1 as 
default port regardless of any other devices (mouse etc. ) connected. 

08/31./05  page 7 



 Easylon Analyzer 

In the LNA.INI file on the installation disk the PC’s COM2 is set as port for communication 
with the Analyzer. It can be changed by editing the according line in the LNA.INI file.  

. 

. 
[LNA] 
COM=2 
. 
 

Other entries must be adjusted according to the operating system used. The AUTOPACKET 
entry can be modified from the Analyzer Program’s menu as well. 
 

 Win 3.x Windows 95 Windows NT 

COM 2 2 2 

BAUDRATE 115200 (max) 115200 (max) 57600 max. 

AUTOPACKET 0 0 0 

WINCOM 0 0 / 1 1 

Table 1: Settings in the LNA.INI file 
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2.4 Network Interface Driver Installation 

The Analyzer Box can be used as a network interface. The network interface driver 
“lnadrv.exe” is contained on the disk along with the Analyzer software. The network driver 
for MS-DOS supplied with the Easylon Analyzer has been designed in accordance with the 
specifications of the Echelon Corporation. For information on the network driver interface 
which is required to develop applications, please refer to the “LONWORKS Host Application 
Programmer’s Guide” from Echelon. 

The “lnadrv.exe” file is copied onto the hard disk of your computer by the Analyzer setup 
program. The network driver requires 1.1 Kbytes of resident program code. 

Installation 

The network driver is installed in the system as device LON1 by adding in the “config.sys” 
file the line 

device=lnadrv.exe /C[communication port] 

or 
devicehigh=lnadrv.exe /C[communication port] 

[communication port] = 1 – 4  (COM1 – COM4) 

Options 

The following options can be used: 

/C Communication port setting (default = COM1) 

/D Setting of device number 
The device number may be in the range from 1 to 9 (LON1: – LON9:). If this option is 
not specified, the network driver will be defined as LON1: (default). If another network 
driver has already been installed with the same device number, this will result in the 
error message: 

Invalid or duplicate device name 

If the parameter /D is specified without entering a subsequent numerical value, the de-
vice number will be assigned automatically. If all possible device numbers have already 
been assigned to other network drivers, this will result in the error message: 

LON1: ... LON9: already defined 

/B Setting of communication baud rate 
 

Setting Baud rate 

/B192 19,200 

/B384 38,400 

/B576 57,600 

Default 115,200 
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The “lnadrv.exe” file can also be called from the DOS command line in the same manner as a 
normal program, to show all the network drivers installed in the system, the appurtenant 
device names and their storage requirements. 

/H will display an explanation of the options 

/R  The option /R additionally enables modification of the device number. 

 Example: lnadrv -r13  
   changes the name LON1: to LON3: 

If the first device number does not exist, or if the second number has already been as-
signed to another device driver, the message 

Invalid or duplicate device name  

will appear. The renaming of device names is not restricted to network interface devices 
defined by this network driver and can also be applied from a Windows DOS box as a 
global function for the entire system, including all Windows applications. 

Instead of the slash ‘/’ it is also possible to enter a minus character ‘-’ to identify the options. 
No distinction is made between upper case and lower case characters. 

The network driver supports only one Analyzer. If several of these are attached to the com-
puter, the network driver must be installed an appropriate number of times in the 
“config.sys” file.  
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3 Tutorial 

During installation of a LONWORKS network communication connections and binding of 
network variables have to be checked. The Easylon Analyzer’s box can be connected to the 
network and is used to generate a list of the available nodes in the domain to which it belongs 
itself. When using the Easylon Analyzer for maintenance and problem solving of existing 
networks, you will apply the filter and trigger functions more often or run consistency checks 
on the connected network and against a previously saved NEURON Chips and interconnec-
tions map. 

This tutorial takes you through a typical session step by step. Not all steps are necessary, al-
though some cannot be taken without the preparation in previous steps. You will find out the 
most efficient way of using the Easylon Analyzer only by putting the tool to good use in your 
own environment. Of course, Gesytec is always interested in your reactions and suggestions; 
send them to the address listed on the first page of this manual. 

If you need specific commands and options that are not discussed in this tutorial, please check 
the reference manual (in chapter 5). The command descriptions in that chapter are listed by 
the order in which they appear in the menus and the order in which the menus appear in the 
menu bar. For an alphabetic list of commands, see the index. 

Step 1: Connecting the Easylon Analyzer hardware 

The Easylon Analyzer makes use of a hardware device: the Analyzer Box or an Easylon VNI 
Interface. Connect the Analyzer Box (RS232 connector (fig. 2/4) to the PC using the cable 
with the 9-pin D type connectors. Make sure the cable is connected to the serial port of the 
PC which is indicated in the LNA.INI file in the “WINDOWS” directory. Connect the 
Analyzer to the network. Note that interface type and Baud rate should comply with that of 
the network segment to which it is connected. The type label of the Analyzer indicates its 
interface type. 

Connect the Analyzer’s power supply. The “Stat” LED (fig. 2/5) will start blinking. 

Step 2: Starting the Analyzer software 

 

When starting the Analyzer software (by double-clicking its icon from within Windows), 
“Welcome” dialog box appears in which the network access device to be used has to be selecte
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Figure 3: The “Welcome” dialog 

If the network acces hardware is running properly the text box should look like it is shown in 
the above figure(possibly with higher version numbers). You can always see the current 
software release in the “About Easylon Analyzer“ dialog box.  

 

Figure 4: The “About Easylon Analyzer” dialog box 

If no connection exists between the PC and Analyzer Box, “comm_err” is displayed in “About 
Easylon Analyzer”. In this case, please check the connection with the Analyzer and make sure 
the “LNA.INI” file is placed in the Windows home directory where it can be found by the 
Analyzer program (see “Installing the software”). This file indicates to the Analyzer program 
which serial port on the PC is to be initialized and used by the Analyzer software. A 
description of this file is given in chapter 5, the Reference Manual. 

It is also possible that the text box displays a trash message. In this case, please read the ap-
propriate section of the "Troubleshooting Guide" in chapter 4. 
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NOTE: Any changes you make to the connection or setup are not automatically updated in the 
Analyzer firmware text box. In order to update the information, you need to close the “About 
Easylon Analyzer” box and reopen it by calling the “About Analyzer” command from the 
“Info” menu. This has to be done in order to initialize the communication between the PC 
and the Analyzer correctly. Before you haven’t seen the Analyzer firmware version in the 
“About Easylon Analyzer” dialog box, you cannot use any of the functions of the Easylon 
Analyzer. 

Step 3: Scanning a network domain 

A unique feature of a LONWORKS network is its self-documentation ability: each NEURON 
Chip holds information on its network variables and will pass the information to another 
NEURON Chip in its domain, when it receives the appropriate request. The NEURON Chip in-
side the Analyzer can therefore use this standard functionality to actively extract information 
from all the other NEURON Chips in the same domain. The information is then passed on to 
the PC, where it can be inspected and stored for later use (e.g. in consistency checks, to find 
out whether some nodes are not responding or whether some network variables are not 
bound). The quality of the information gained by this depends on the NEURON Chip type 
(3150 or 3120) because of their different memory capacity as well as on the extent of infor-
mation stored in the node by its manufacturer and the application programmer. 

The network information is also used to enhance the functionality of the Analyzer program: 
packet information is displayed in an intelligible way using node names rather than node ad-
dresses and network variable names and types rather than cryptic hexadecimal message con-
tents. Inspecting network variables and setting their values (with input variables) becomes 
possible with the “NV-Browser” command. Also, setting filters on the basis of network vari-
ables becomes possible, through the “New NV-Filter” command. 

All in all, there are sufficient reasons for advising you to scan the network domain you want 
to investigate, prior to doing more specific analysis or trouble-finding work. 

To obtain a map of the network domain that you want to check, you need to first determine 
which domain your Easylon Analyzer hardware should be part of: the Easylon Analyzer’s 
NEURON Chip can only generate messages to nodes which it has found in its own domain. 
Although a regular node can be part of two domains (to form a gateway between two do-
mains, some nodes must have this double domain inclusion), this option is not supported in 
the Analyzer software: it would not make much sense, since you usually only analyze one 
domain at a time. However, concerning the recording of messages, the complete network 
traffic can be listened to.  

 

Figure 5: The “Analyzer Node Parameter” dialog box 
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You can set the domain to scan by choosing the “Analyzer Node” command from the “Ana-
lyzer” menu. The dialog box allows you to choose the domain name and give the Analyzer’s 
NEURON Chip a unique logical address (numbers of subnet and node) in that network do-
main.  

Note that the first option in the displayed domain list is blank: this indicates the so-called 
"null-domain". This type of domain has an identifier of 0 bytes length, which means no iden-
tifier has to be specified for the Analyzer’s NEURON Chip. If the nodes in your network be-
long to a null-domain (i.e. the domain ID for either the primary or secondary domain is de-
fined as 0 bytes long), the Easylon Analyzer will find all nodes belonging to this domain. By 
default, the Easylon Analyzer hardware is set to the null-domain. Only if you are using non-
zero domain identifiers and want to check a specific domain inside your network, you have to 
set the domain ID in the “Analyzer Node Parameter” dialog box. 

  Now you choose the “Scan Network” command from the “Analyzer” menu or you can click 
on the corresponding button on the toolbar and click “Scan”. Depending on the size of the 
domain to be scanned this can take a while, since a lot of messages are required to build a 
complete map of the nodes in the network, their network variables and their current status. 
When working with a substantial domain, this might be a good moment to take a short 
break while the Easylon Analyzer is working for you … 

 

Figure 6: “Scan Network” in progress 
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Step 4: Analyzing the network’s node map 

When the Easylon Analyzer has finished scanning the network, a list of the network nodes 
will be displayed in the “Nodes” window. The information in this window includes the 
unique NEURON IDs, the ID strings defined by the programmers of the applications, the lo-
cation, subnet and node numbers and the node self-documentation. The network variables 
are not shown in this Nodes window, but can be made visible through the “NV Browser” 
command in the “Info” menu, as is described in step 12 below. 

 

Figure 7: A Nodes window 

If you have found some defects in the network’s nodes map (e.g. when one or more nodes 
were not found and turned out to be powered down), you may want to re-scan the network 
after making some changes. You do not need to scan the entire network each time: by de-
fault the “Load unknown nodes only” option is enabled, causing only "new" nodes to be con-
tacted. This may save a lot of time, but if you change some of the nodes already found 
(change their logical addresses or exclude them from the analyzed network domain), you may 
want to do a full re-scan. In that case you need to disable the “Load unknown nodes only” 
option by clicking the box. 
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Step 5: Running a consistency check 

The Nodes window gives information on the available nodes, not on the consistency of the 
domain (logical node addresses) or on the question whether network variables are bound or 
not. To obtain this information you will have to request a consistency report. 

To do so, execute the “Consistency Report” command from the “View” menu. This command 
causes a report window to be opened, in which information on the previously scanned domain 
is displayed. The dialog box for this command allows enabling of the NEURON Chip level 
consistency and consistency on the level of network variables separately. By default, both 
parts of the report are generated and shown in the report window. 

 

Figure 8: A Report window 
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Step 6: Recording messages into the packet buffer 

 

  

To start recording messages into the Easylon Analyzer’s packet buffer you click the [New 
Recording] button on the toolbar or select the “Start Recording” command from the “Ana-
lyzer” menu1. Note that the Packets window does not change its contents: The packets still 
have to be read into the PC explicitly. The status bar shows the number of recorded packets 
that are currently stored in the packet buffer and the packets per second recorded.  

NOTE The packet buffer is limited in size and can only store a limited number of packets (about 
18 000 with the current version). When the packet buffer is full, the oldest packets will be 
written over. Packet buffer memory is freed by transferring packets to the PC. This can be 
done with one of the “Get…” commands, which will always transfer the “oldest” packets first 
to the PC. 

 

Figure 9:  The “Analyzer” menu 

  Clicking on the [Stop Recording] button or selecting the “Stop Recording” command in the 
“Analyzer” menu causes the Easylon Analyzer recorder to skip all further packets. The packet 
buffer stays untouched: the assembled packets can still be read into the PC after recording 
has stopped. 

When restarting the recording of packets, you have the choice between “Start Recording”, 
which resumes adding packets to the packet buffer again, or “New Recording”, which first 
clears the packet buffer. Note that the [New Recording] button in the toolbar is associated 
with the “New Recording” command. 

                                                       

1 There is a difference between the "New Recording" and the " Start Recording" commands, as for a "New Recording" the Analyzer’s 

buffer will be cleared prior to recording. 
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Step 7: Getting messages from the packet buffer 

Messages that are recorded in the packet buffer of the Analyzer can be read into the packets 
window on the PC using one of the “Get…” commands from the “Analyzer” menu. The dis-
play of message information is controlled through the first three options in the “View” menu. 
By default, the Message Address and Message Data modes are selected and the information 
contains sending node, addressed node, type of message and time at which it was recorded. 

 

Figure 10: A Packets window with all display options selected 

The “Get all packets” command causes reading of all packets which were available at the 
moment of issuing the command. Depending on the number of packets recorded into the 
packet buffer, this may take quite a while, due to the serial communication between the 
Analyzer and the PC. While the packets are transferred, the packet buffer is continuously 
filled again, unless recording is previously switched off.  

 
 

  

If the “Get 100 Packets” command is used instead, at most 100 packets are read in from the 
packet buffer, and as many empty spots in that packet buffer become available for new 
packets to be recorded. The [Get 100 Packets] button is equivalent to the “Get 100 
Packets” command. 

 
 

  

In order to keep the information in the packets window manageable (e.g. to keep you from 
endless scrolling back and forth), the packets are divided in pages of 400 packets each. The 
“Prev Page” and “Next Page” commands and their associated buttons in the toolbar are 
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automatically enabled or disabled if appropriate. Through these commands you can effi-
ciently navigate through large amounts of packets. 

Step 8: Finding specific messages 

If you need to look at specific messages, for example if one of the nodes does not seem to an-
swer on requests or seems to give an incorrect response, you may want to use the “Find” 
command. This will cause the next occurrence of the specified message to be displayed, i.e. 
the window is scrolled to the position where the specified message is found. Note that this 
may involve moving one or more pages down. 

 

Figure 11: The “Find” dialog box 

If you indicate search keys you must explicitly click the check box next to the key in order to 
enable it. Clicking an enabled check box disables the associated search key, but does not 
change the key description, so that it may be used again in future searches. You can use a 
number of keys in order to enlarge the set of searched packets or to reduce it (clicking the 
“Logical AND” option). Instead of using the subnet and node IDs of nodes or hexadecimal 
patterns from the message contents, you may want to search on the basis of Prog-IDs or lo-
cations or on the basis of network variable names. The lower part of the “Find” dialog box 
allows you to do this. 

Check the “Backward" box to reverse searching from newer to older packets. 

Searching for the next occurrence of the same packet can be done using the “Find Next” 
command (or pressing Ctrl-G). This command works from the previous packet that was 
found using the “Find” command, i.e. when selecting another packet by hand, this will not 
become the starting point for a renewed search. The search direction is depending on “Back-
ward" box. Even if you have moved pages up or down since the last found packet was dis-
played, the “Find Next” will return to the correct page to show the first occurrence of a 
similar packet after the last found. 

When looking for causes of problems in your network, you will want to move around the 
packets window and often return to the same selected packet. This is possible through the 
“Show Selection” command in the “View” menu, but only to a limited extent: some com-
mands cause another packet to be selected. Of course you would expect this from the “Find” 
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and “Find Next” commands, but the “Next Page” and “Prev Page” commands also have this 
effect. When a new page is made visible, the selected packet becomes the first (when moving 
to the next page) or the last (when moving to the previous page) packet on the new page. 

Apart from the “Show Selection”, there is a “Show Trigger” command, which scrolls the 
packets window to display a trigger packet (see step 10 below). The trigger packet is pre-
ceded by a “T” in the Packets window. 

Step 9: Setting filters 

Recording all packets into the Analyzer’s packet buffer, getting them into the PC and 
searching through pages full of packets to find the ones that show where a possible problem 
with your network lies may take a lot of time. You can minimize the time needed by having 
the Easylon Analyzer only record certain packets into the packet buffer. By defining and ac-
tivating one or more filters the recorded information becomes more to the point. Remember: 
you cannot delete single packets from that window. To save yourself a lot of scrolling, in-
stalling filters on the Easylon Analyzer’s recording facility is a good idea. On the other hand, 
defining and activating too strict filters may keep you from detecting the clue to a solution of 
a network problem. 

Using filters involves describing the characteristics of a filter and naming it, defining the fil-
tering condition and actions associated with it and selecting several filters into a filter group. 
Finally this set of filters has to be activated. These steps are explained below along with their 
most important options. For a detailed description see the appropriate sections in the Refer-
ence Manual (in chapter 5). 

For each filter to be defined you start with either the “New NV Filter” or the “New Address 
Filter” command in order to describe the filter, i.e. determine message characteristics to 
which the network traffic has to be compared to. The “New NV Filter” command works on 
the basis of network variables and allows selection of a certain network variable. Of course, 
the Analyzer program must know about the NVs of the connected network, so a scan and 
upload network has to be run before. It is also possible to use a previously saved network de-
scription which has been read in from file, but you have to make sure the description still fits 
the network domain you are analyzing.  
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Figure 12: The “New NV Filter” dialog box 

To describe a filter for a certain network variable first select a node by ProgID/Location 
which contains the NV and subsequently select the network variable desired. The NV’s I/O 
direction, its length and current value are shown, for SNVT type NVs the upper field gives 
the intelligible expression and the lower one the hexadecimal representation. The “Match 
Value” box allows specification of a certain value of the NV to be matched if used as a filter. 
This value has to entered in hexadecimal notation. If you do not specify a match value, all oc-
currences of the network variable in the network communication will match the filter de-
scription.  

It is also possible to define filters based on node addresses rather than on network variables. 
The “New Address Filter” command from the “Filter” menu causes the following dialog box 
to appear: 

 

Figure 13: The “New Address Filter” dialog box 

08/31./05  page 21 



 Easylon Analyzer 

Describing filters on the basis of node addresses is done through identification of source or 
destination addresses and optionally indicating service type plus address format (broadcast, 
group or subnet/node). 

If you want to use multiple filters you must give each filter a unique name, so that you can 
identify it in the “Filter Group”, “Modify Filter” or “Delete Filter” commands later on 
(otherwise, you will have to choose from a list of filters named “Untitled”). 

After filters have been defined and named, filtering conditions have to be defined and com-
mands need to be associated with these conditions. A filter definition merely describes some 
characteristics of packet, not how to use these for filtering. In the “Filter Group” command 
you determine both the filtering condition and the associated command for each of the pre-
viously defined filters. Furthermore you here compose a set of previously defined filters to the 
filter group you work with.  

 

Figure 14: The “Filter Group” dialog box 

To specify a filtering condition and associated command choose “Add…” first: the button to 
the right will display a pull-down menu with all available filters. Choose one and subse-
quently choose a filtering condition for it by clicking the lower pull-down menu button: the 
options for conditions are “if equal” or “if unequal”. Finally you have to indicate the action to 
be taken by the Easylon Analyzer when a filtering condition has been met: show the packet, 
ignore the packet or — and this last option is described in the following step of this tuto-
rial— use the packet as a trigger. 

  
 

  

After all this the defined filters can be activated through the “Activate Filters” command in 
the “Filter” menu or through the equivalent button in the toolbar. They can be deactivated 
through the “Deactivate Filters” command or through the equivalent button. This allows a 
flexible use of the filter option: you do not need to remove filter definitions if you want to 
temporarily deactivate them. 

The filter definitions are saved to file (when you choose the “Save” command from the “File” 
menu) and can immediately be re-activated each time you run the Easylon Analyzer with this 
file. The file is the same as is used to store recordings of packets and uploaded network 
information. 
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Step 10: Using triggers 

When defining a filter you specify a certain type of messages to be recorded, or to be ignored. 
In some cases you will want the Easylon Analyzer hardware to stop recording automatically 
when a specific type of message arrives. This is possible using one of the defined filters as a 
trigger. 

 

Figure 15: The “Filter Group” dialog box with Trigger command 

Setting a trigger is done by first selecting a named filter, then choosing the “equal to” condi-
tion and finally assigning the “trigger” command to this filter. Further options for a trigger 
are the occurrence of the specified trigger packet type before recording will stop and the 
number of packets that shall be recorded after the (last) trigger has been detected. 

Note that setting the trigger as explained above does not automatically activate it. You can 
do so by activating all filters through the “Activate Filters” command or the equivalent but-
ton in the toolbar. Instead, you can also activate all defined filters and triggers in the “Filter 
Group” dialog box, by clicking its “Activate” button. 

Step 11: Saving window contents to a file 

To save the current contents of a window to file you simply choose one of the “Save” com-
mands from the “File” menu. If the window contents was not saved before, Easylon Analyzer 
prompts you for a file name. This is the same dialog box as you would get when executing 
the “Save As” command on an already saved and named file. It allows you to navigate 
through your file system to determine where the file is to be placed, and of course it asks you 
to name the file. 

When using the “Save As Text” command, the file format is readable by other applications 
(standard ASCII text), but only the packet information is written out and not all of the in-
formation available in the Packets window is stored. See the Reference Manual chapter for a 
description of the format used in this command. If you write out information to a text file the 
window remains untitled, and Analyzer will prompt you for a file name and location the next 
time you want to “Save” the file. 
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Saving a file overwrites the existing file with the same name. If you give an existing name in 
the “Save As” or “Save As Text” commands, you are asked whether the file should be re-
placed or not. 

Step 12: Using the NV Browser 

The NV Browser allows investigating the status of network variables. This command is en-
abled if a network upload is available (i.e. after scanning the network or after reading in a 
previously saved network upload from file). On the basis of the self-documentation of the 
LONWORKS network, the Browser enables easy navigation through the network and inside 
each of the NEURON Chips in it:  

 

Figure 16: The “NV Browser” dialog box 

Clicking one of the available nodes in the list on the left hand side makes the list of its NV 
names appear in the NV list to the right. By selecting one of these its current value is dis-
played. The value is updated each time the NV is selected. 

If you have selected an input variable the allows setting the value of the variable: change the 
value in the “Set” window and click the “Set” button to do so. The type information is only 
given if the network variable is of the SNVT type; in such cases, the indicated value is inter-
preted, whereas the “Set” value is hexadecimal. 
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4  Troubleshooting Guide 

The mouse dies when starting Easylon Analyzer 

You have probably told Windows that the Analyzer is connected to the same serial port to 
which the mouse is attached. Since Windows does not check on connected mice and overrules 
the serial port allocation your mouse driver has been killed when starting the Easylon 
Analyzer. 

Remedy: Change the serial port setting in “LNA.INI” file and restart windows. 

“comm_err” in the “About Easylon Analyzer” box  

This message indicates an error in the communication between the Analyzer Program on PC 
and the Analyzer hardware. First, the Analyzer might be switched off. If the Analyzer has 
power, at least one LED should be blinking. With packets detected on the network the LON 
LED is blinking with every detected packet. 

Secondly, the connection between the Analyzer and the PC might not be correct: either the 
cable is not attached or possibly the wrong cable is used to make the connection. Some cables 
have different connection schemes, so make sure you are using only the cable which has been 
delivered with the Easylon Analyzer. 

NOTE In each of the above cases a change in the connection is not automatically detected by the 
Analyzer software. After making the change you will have to close the “About Easylon 
Analyzer” dialog box by clicking OK and re-open it by calling the “About Analyzer” com-
mand from the “Info” menu. This needs to be done before using the Easylon Analyzer, since 
the comm_err status must be cleared. If you have not seen the message indicating the Ana-
lyzer firmware version number the Easylon Analyzer is not initialized correctly and cannot be 
used. 
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Trash in the “About Easylon Analyzer” dialog box 

Figure 17: The “About Easylon Analyzer” dialog box 

In this case you have probably attached the Analyzer Box to a different serial port than what 
is written in “LNA.INI”. There is another device driver active on the serial port responding in 
an unintelligible protocol. This is what makes the trash appear in the “Firmware” text box. 

Remedy: Change the settings in “LNA.INI” or change the connector on the PC to the correct serial 
port and restart the application. 

No packets are recorded 

First of all, this might not be a problem at all: if no messages are generated on your network 
then the Easylon Analyzer will not detect any. 

If the network should generate some messages (LON LED is blinking with every message de-
tected) but none are detected by the Easylon Analyzer, it might be that you have made an 
error when defining filters: if you define too strict filtering conditions no messages of the 
specified type may occur on the network and the Analyzer’s packet buffer will remain empty. 

Remedy: De-activate the filters and wait for messages to appear. 

If the problem is not solved by deactivating filters, there might be a problem with the con-
nection between the Analyzer and the network that you are trying to analyze. 

Remedy: Check whether both ends of the network connection cable are plugged in. If they are and no 
connection seems to be there anyway try another connection cable or another plug-in slot on 
the network. 

If nothing seems to work, try to upload the network first and activate the Nodes window to 
see whether the network has been found at all. 
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No nodes are shown after scanning the network 

The first problem might be that the domain settings for the Easylon Analyzer’s NEURON 
Chip are such that no nodes can be found, since there is no such domain in your network. 
Check and change the domain setting for this NEURON Chip using the “Analyzer Node” 
command and retry the network scan. Note that the nodes in your network may be in 2 
domains (for possible gateway functions), but the NEURON Chip in the Analyzer only be-
longs to one domain: the one you are trying to analyze. 

If the domain setting is OK but still no nodes are found when scanning the network, you 
might not have connected the Analyzer to the network, or the network might not be oper-
ating. The network to be uploaded then does not contain any active nodes except the Ana-
lyzer. So queries from this node are not answered and the Easylon Analyzer finds no nodes: 
the “Scan Network” dialog box briefly shows the message “Start Scan” and then exits without 
further messages. 

 

  

Check the connection between the Analyzer and the network you want to analyze and try 
scanning the network again after you have first started a “New Recording”. 

If the status bar shows >0 packets in Analyzer’s packet buffer after the unsuccessful scan, the 
network seems to have no active nodes, i.e. the nodes in your network may not be powered 
on or some other reason may exist for the Easylon Analyzer to not find any nodes. 

Remedy: Check the power LEDs on some of your nodes. If they are on and you are certain that they 
belong to the domain that you are trying to scan something else is wrong in your network. It 
might be that all of your network nodes are switched off-line and cannot respond to any que-
ries of the Analyzer’s NEURON Chip anymore. The methods to find back and revive these 
nodes are device-specific and cannot be covered by this User Manual.  

One node does not show up in the network scan 

If one and always the same node in your network does not show up in a network scan, al-
though the Easylon Analyzer initially indicates the correct total number of nodes available in 
your network (“Scanning <#> of <total>” is displayed during the network scan) probably 
your Analyzer’s NEURON Chip has the same subnet and node ID as the NEURON Chip of the 
node not found. This effectively hides messages coming from this node: the Easylon Analyzer 
will always discard a response it assumes originating from itself. 

Remedy: Change the logical address of the Analyzer’s NEURON Chip by choosing the “Analyzer Node” 
command and typing in numbers that are not used in your network. The simplest is to use a 
subnet number that is not used in the network domain you want to analyze. When scanning 
the network again, you can choose the “Load unknown Nodes only” option to save time. This 
should cause the missing node to appear. 
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Scanning the network results in a comm_err 

 

Figure 18: The “Scan Network” dialog box 

If the network is not terminated properly a comm_err may occur when scanning the net-
work.  

Remedy: Check the bus termination of the network and reset the interface between Analyzer and 
network by choosing the “About Analyzer” command in the “Info” menu. This should clear 
the status of the Easylon Analyzer hardware and the buffers between the this device and the 
PC. Then retry scanning the network. If the problem does not seem to disappear you might 
have to reset both the network and the Analyzer to get them back into synchronization. Re-
member that in any case you will have to issue the “About Analyzer” command to reset the 
status of the Easylon Analyzer hardware and its connection to the PC before trying any fur-
ther commands like scanning the network or recording and reading in packets. 
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5 Reference Manual 

5.1 Hardware Reference 

This chapter refers to the Easylon Analyzer Box 

5.1.1 General information 

Dimensions 

The Easylon Analyzer Box dimensions are 169 x 105 x 59 mm without connectors.  

Power supply 

Input Voltage    12–24 V AC/DC 

Power consumption  about 8 W 

Connectors   Jack connector 

Operating conditions 

Temperature operating  0 – 50 °C (32 to 122 F) 
  non-operating  -20 – 80 °C (-4 to +176 F) 

Humidity   90%, non-condensing 

Protection class   IP20 

EMC   EN55022 Level B 
E-Field accord. IEC801-3 
Burst accord. IEC-4/3 

CE Compliance   DIN EN 50081-1 
DIN EN 50082-2 

UL Compliance   V01 

5.1.2 Technical information 

The Easylon Analyzer hardware consists of two main parts: the network node part with the 
NEURON Chip and the recorder part. The specifications of these and the interfaces to net-
work and PC and of diagnostic indicators are as follows: 

Network node part 

CPU   Echelon NEURON Chip 3150® Chip, 10 MHz 

Memory EPROM   32 Kbytes, 70 ns 
  SRAM   24 Kbytes, 55 ns 
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Recorder part 

CPU   Motorola MC 68331, 14,72 MHz 

Memory Flash-EPROM   1 Mbytes 
  SRAM   512 Kbytes 

Network Interface  

On each Analyzer only one of the following network interfaces is available. Check the type 
label! 

- FTT-10: 78 kbps, free topology transceiver 

- TPT/XF 1250: 1,25 Mbps, transformer coupled twisted pair 

- TPT/XF 78: 78 kbps, transformer coupled twisted pair 

PC Interface 

Connector COM:  RS232 interface for serial connection to the PC with 
Analyzer software  

Diagnostics 

LED   3 indicators on the front panel  
(details see below) 

Watchdog   voltage level supervision 

5.1.3 LED Indicators 

The Analyzer is equipped with 3 LED indicators on the front panel. The purpose of these and 
the meaning of the signals they will give you are as follows: 

 

Figure 19: The Easylon Analyzer’s front panel 

Stat 
 cont. If this LED is continuously on, a general error has occurred making correct 

functioning of the Analyzer impossible. For instance a communication error 
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during the firmware download may have occurred. Try to reboot the 
Analyzer by briefly disconnecting the power supply and choosing again the 
“About Analyzer” command from the Info menu. If the error recurs, contact 
your technical support engineer. 

 1 Hz This LED is blinking steadily (at 1 Hz) when Analyzer box and program 
are running correctly. 

 4 Hz This LED is blinking fast when the Analyzer is recording packets into its 
packet buffer. 

LON This LED is switched on whenever communication packets are registered on 
the network segment to which the Easylon Analyzer is connected. 

SERVICE If this LED is on, an “MIP” error has occurred in the network node part of 
the Analyzer. The LED is attached to the service pin of the NEURON Chip 
and has the same function as a service LED on other nodes. This LED 
should be off before being able to use the Easylon Analyzer.  

5.1.4 Format of the “LNA.INI” file 

The “LNA.INI” file contains initializing data for the Analyzer software. First of all, the serial 
port to be used on the PC is identified here. Also, a list of the last 4 opened files is kept in 
“LNA.INI”: these files show up in the “File” menu for fast access. 

The file format looks is as follows: 
 

[LNA] 
COM=2 
BAUDRATE=115200 
AUTOPACKET=0 
 
[Recent File List] 
File1=C:\EASYLON\TEST\HAUSNETZ.LNA 
… 

Settings with respect to the different operating systems are given in Table 1: 
 

 Win 3.x Windows 95 Windows NT 

COM 2 2 2 

BAUDRATE 115200 (max) 115200 (max) 57600 max. 

AUTOPACKET 0 0 0 

WINCOM 0 0 / 1 1 

Table 1: Settings in the LNA.INI file 

NOTE: The LNA part is important since this indicates to the Analyzer program where the connec-
tion to the Analyzer is made. In the LNA.INI file you received with the Easylon Analyzer the 
port is set to COM=2, If this file cannot be found —remember it must be in the Windows 
home directory— the communication port defaults to COM1 of the PC.  

On most PCs this port is used for the mouse. So, if the Analyzer program cannot find the 
"LNA.INI" file with a different assignment, the mouse will die when starting the program. 
Make sure this section of the file and the serial port used to communicate to the Easylon 
Analyzer hardware correspond and that the file is placed in the Windows home directory. 
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The "Recent File List" may be empty when you have not opened and saved files with Ana-
lyzer before. Whenever you open or save a file from the Easylon Analyzer program the file-
name is added to the list. Only the last four opened files are shown in the "File" menu.  
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5.2 Command Reference 

5.2.1 The File Menu 

The commands in the “File” menu let you handle files, print window contents, or exit from 
Analyzer. The various commands are explained below. 

 

Figure 20: The File menu in its pulled-down state. 

New The “New” command causes a new file to be opened for storage of subsequently collected 
packets, possibly combined with uploaded NEURON Chip information. When this command 
is issued an empty window appears with a temporary title (Easylon Analyzer - (Untitled#), 
with  # being a counter for the new windows in one session). This title is used until the con-
tents of the window are saved in a file. By default a new file comes up with the packets win-
dow, of course without any packets being displayed. 

Open The “Open” command allows an existing file to be opened. Issuing this command causes a 
dialog box to appear, allowing you to navigate through your file system and open the needed 
file. This dialog box is shown below: 

 

Figure 21: The “Open” dialog box 
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The “Directories” scroll box shows the current directory at the top with subdirectories below. 
By double-clicking on one of the subdirectories it is opened and the possibly nested directo-
ries are shown. Changing to a different disk drive is done by clicking the button next to the 
“Drives” box and choosing a drive from the pull-down list.  

On the left side a file scroll box is shown listing the files available in the currently selected 
subdirectory. A filter on the files to be listed can be selected by clicking the button next to 
the “File format” box and choosing one of the available file formats from the pull-down list. 

When opening a file it will come up with the “Packets” window showing the packets saved in 
the last session. The window will show the file name as its title. If no packets have been saved 
in the file, the window will remain empty. By choosing the “Nodes” command from the 
“Window” menu, you can make a previously uploaded and saved network description visible 
(if a network description was saved in the file). 

You can also choose this command by typing <Ctrl-O>. 

Close The “Close” command causes the file with the topmost window to be closed. All its windows 
will disappear. If the contents of this file was changed since the last time it was saved, a dia-
log box will appear asking whether it should be saved prior to closing. Clicking “Yes” will 
save the current contents of the file (the file name is in the title bar of all windows belonging 
to that file). If the file has not been saved before and it is “[Untitled]”, the “Close” command 
then functions as the “Save as…” command described below. Clicking “No” causes the cur-
rent file contents to be discarded and all its windows to be closed. Clicking “Cancel” makes 
the dialog box disappear without changes to either the file or the displayed window. 

Note that this does not work when closing a window through the standard MS Windows 
close box, since Windows does not know about the combination of windows that are related 
to one single file. However, closing the last window of a file will cause the “Save” prompt to 
appear. 

Closing the last active window (either through this command in the “File” menu or through 
standard Windows close commands — double-clicking the upper left box in the window or 
pressing Ctrl-F4) causes the Easylon Analyzer program to display a minimal menu bar, con-
taining a limited set of available commands. 

Save If the active window has already a saved file attached to it (the filename is used in the window 
title), the “Save” command causes the current contents to be saved to the associated file on 
the harddisk. Previous file contents are overwritten. Always the complete current information 
is saved, i.e. the Packets window contents and the result of the last scan and upload with the 
latest states and values queried from the network nodes and NVs. 

If no file was yet attached to the active window, the “Save” command behaves like the “Save 
As…” command described below. 

You can also choose this command by typing <Ctrl-S>. 

Save as… The “Save As…” command allows saving the contents of the active window (and associated 
windows, if a network upload and consistency check have been done) into a file. A dialog box 
is displayed asking for a filename and letting you navigate through the PC’s file system and 
decide where to place the file. 
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Figure 22: The “Save as…” dialog box 

The directory structure to the right lets you select a directory by double-clicking it. On the 
left side, the files existing in the selected directory are shown. Give the name of the file to be 
saved in the text box above the file list, and click “OK” to save. 

Save as Text The “Save as Text…” command allows saving the contents of the active Packets window in 
ASCII format. Not all of the data available in a normal Analyzer Packets window are written 
to the text file: only the packet number, time stamp, message type, the group number and 
group member of acknowledge and response messages inside a group addressed transaction 
and address information are saved, separated by tabs (and one packet to a line). This format, 
as shown below, is independent of the view format in the Packets window. 

 
Gesytec Easylon Analyzer Version 1.50 
25.4.1995 1 0 
1 10:10:05.321 ACKD 0 S1 N1 G2    H_Netz  4 80010A0C1C 
2 10:10:05.325 ACK 0 S1 N4 S1 N1 G2 M2 H_Netz  4  
3 10:10:05.327 ACK 0 S1 N3 S1 N1 G2 M1 H_Netz  4  
4 10:10:05.329 ACK 0 S1 N5 S1 N1 G2 M3 H_Netz  4  
5 10:10:05.613 ACKD 0 S1 N2 G1    H_Netz  11 80000B60 
6 10:10:05.623 ACK 0 S1 N4 S1 N2 G1 M2 H_Netz  11  
7 10:10:05.626 ACK 0 S1 N5 S1 N2 G1 M3 H_Netz  11  
8 10:10:05.628 ACK 0 S1 N3 S1 N2 G1 M1 H_Netz  11  
9 10:10:06.181 ACKD 0 S1 N14 G9    Aufzug  3 800602050009 
10 10:10:06.187 ACK 0 S1 N20 S1 N14 G9 M3 Aufzug  3  
11 10:10:06.189 ACK 0 S1 N17 S1 N14 G9 M1 Aufzug  3  
12 10:10:06.282 REM/MSG 0 S1 N14 G9    Aufzug 0A 3 800602050009 
13 10:10:06.286 ACKD 0 S1 N1 G2    H_Netz  5 80010A0C1D 
14 10:10:06.294 ACK 0 S1 N18 S1 N14 G9 M2 Aufzug  3  
15 10:10:06.296 ACK 0 S1 N5 S1 N1 G2 M3 H_Netz  5  
16 10:10:06.298 ACK 0 S1 N4 S1 N1 G2 M2 H_Netz  5  
17 10:10:06.383 REM/MSG 0 S1 N1 G2    H_Netz 0C 5 80010A0C1D 
18 10:10:06.390 ACK 0 S1 N3 S1 N1 G2 M1 H_Netz  5  
19 10:10:06.484 ACKD 0 S1 N13 G8    Aufzug  4 800601020001 
20 10:10:06.492 ACK 0 S1 N18 S1 N13 G8 M2 Aufzug  4  
21 10:10:06.495 ACK 0 S1 N19 S1 N13 G8 M3 Aufzug  4  
22 10:10:06.497 ACK 0 S1 N17 S1 N13 G8 M1 Aufzug  4  

Figure 23: Sample result of “Save as Text…” 

Print The “Print” command allows the contents of the active window to be printed to a connected 
printer. If no printer has been selected, the program will prompt you to do so prior to exe-
cuting this command. The layout of the appearing printer dialog box and the options avail-
able for printing depend on the particular printer driver software that is used. Note that the 
screen layout may be different from the format that is used in printing the data on paper. 

You can also choose this command by typing <Ctrl-P>. 

Print to Text The "Print to Text" command directs the contents of the current window (Packets, Nodes, 
Report) to be printed into a text file rather than on a printer, as with the normal "Print" 
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command. Thus list entries are separated by blanks and lines are terminated with a carriage 
return. 

     1 10:10:05.32 ACKD      4    1/  1 DCF-77   [A031]  -> Group:   2 Domain: H_Netz
                                DCF-Zeit        -> Group           10:12:28
     2 10:10:05.32 ACK       4    1/  4 AEG-Anz  [A003]  ->   1/  1 DCF-77   [A031] Domain: H_Netz
 
     3 10:10:05.32 ACK       4    1/  3 AEG-Anz  [Foyer] ->   1/  1 DCF-77   [A031] Domain: H_Netz
 
     4 10:10:05.32 ACK       4    1/  5                  ->   1/  1 DCF-77   [A031] Domain: H_Netz
 
     5 10:10:05.61 ACKD      11   1/  2 LPT_Temp [A013]  -> Group:   1 Domain: H_Netz
                                Temperatur      -> Group             17.2
     6 10:10:05.62 ACK       11   1/  4 AEG-Anz  [A003]  ->   1/  2 LPT_Temp [A013] Domain: H_Netz
 
     7 10:10:05.62 ACK       11   1/  5                  ->   1/  2 LPT_Temp [A013] Domain: H_Netz
 
     8 10:10:05.62 ACK       11   1/  3 AEG-Anz  [Foyer] ->   1/  2 LPT_Temp [A013] Domain: H_Netz
 
     9 10:10:06.18 ACKD      3    1/ 14 Kopier   [.25]   -> Group:   9 Domain: Aufzug
                                Kopier_Status   -> Group           02050009
    10 10:10:06.18 ACK       3    1/ 20 Tuer     [.2]    ->   1/ 14 Kopier   [.25] Domain: Aufzug  

Figure 24: Print to text 

Print preview The "Print preview" command displays a preview on the screen of the results using the 
"Print" command. 

 

Figure 25: Print preview 

Within the full page view window, you can use zoom and paging buttons to look at specific 
details in the window contents to be printed. From this window you can execute a “Print” 
command by clicking the "Print…" button. You can also switch between displaying one page 
at a time or two pages side by side. To exit this window click the "Close" button. 
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Printer Setup The “Print Setup” command causes a dialog box to appear allowing you to select the printer 
for the window contents that you may want to print. The appearing dialog box and the 
options available for printing depend on the particular printer driver software that is used.  

Recent Files Up to 4 files are listed as the most recently opened and saved files you have been working on. 
This allows for faster opening of often used files than navigating through your file system as 
you would have to using the “Open” command. If you open or close a file it appears as the 
first listed in the active file list inside the “File” menu. 

Exit The “Exit” menu causes a dialog box to appear prompting you for an acknowledgement of 
your wish to exit the program. Clicking “OK” causes all open windows to be closed before 
the program exits. This may cause further dialog boxes to appear, asking whether window 
contents should be saved prior to closing. Clicking “Cancel” in any of the appearing dialog 
boxes causes the closing down of the program to be interrupted at that point. 
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5.2.2 The Edit Menu 

In the “Edit” menu the only active commands in the current version of Easylon Analyzer are 
the “Find” commands. These allow you to search for specific packets inside the already avail-
able ones, i.e. to search inside the contents of the active Packets window. 

 

Figure 26: The Edit menu in its pulled-down state. 

Find… The “Find” command allows you to search for a specific packets inside the active window 
contents. Choosing this command makes a dialog box appear in which you can indicate the 
type of message you want to search for. The search keys include source node, destination 
node or group, message contents (given as hexadecimal data).  

 

Figure 27: The “Find” dialog box 

The options in the “Find” dialog box are grouped in two main fields: one relating to the raw 
message data (this can be used at any time) and one relating to NEURON Chip and network 
variable names (this can only be used when such names are available, i.e. after a network scan 
has been performed or read in from file). The raw message data can be searched using the 
source node/subnet or destination node/subnet or group. Make sure you click the appropriate 
check box next to the specification you have indicated in order to enable the entered search 
key. 

The self-documented data can be used to define a search key on the basis of node or network 
variable names. Clicking the “Logical AND” box to the right makes the selected search keys 
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work in combination, i.e. through this option you narrow down the search for a specific 
packet. 

Check the “Backward" box to reverse searching from newer to older packets. 

You can also activate this menu by typing <Ctrl-F>. 

Find Next The “Find Next” command causes a search for the next occurrence of the packet that was 
searched before (even if such a packet was not found during the previous search). This com-
mand allows you to search repeated occurrences of similar packets without having to answer a 
dialog box every time. 

The “Find Next” command takes the previously found message as the starting point for the 
renewed search. Even if another packet was selected, a “Get until Find” command or a “Show 
Trigger” was executed, the “Find Next” returns to the previously found message before 
searching in the same direction as with the previous “Find” command for the next packet 
complying with the same specifications. 

The “Find Next” command can also be called by typing <Ctrl-G>. 
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5.2.3 The Window Menu 

The commands in the “Window” menu allow you to look at three main parts of information 
gained using the Easylon Analyzer and to display or hide the toolbar and status bar. 

 

Figure 28: The “Window” menu in its pulled-down state. 

Packets The “Packets” command causes the “Packets” window to appear, i.e. the message packets 
previously read in from the Analyzer using a “Get…” command appear in the active window. 
If no packets have been read in yet, the window remains empty. 

 

Figure 29: A Packets window 
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Packets can be shown in a number of different formats, which are controlled by commands 
from the “View” menu. See that section for more details. 

The Packet window in figure 29 above displays the following information: 

Sequence number, time stamp, service type, transaction number, subnet, node, node name 
and location of the source node and of the destination node, network domain, followed by the 
message data. Message data can be explicit messages or NVs with values, which in case of 
SNVT type NVs are displayed as formatted values. 

Sequence numbers are continuous as received on the PC even if recording was interrupted by 
the user or messages are missing because older messages have been overwritten. In case of 
missing packets a dotted red line is inserted.  

The “T” mark in front of the sequence number indicates trigger packets. 

Nodes The “Nodes” command causes the “Nodes” window to appear. If no network was scanned or 
a previously executed network upload has not been saved in the current file this window will 
remain empty. 

 

Figure 30: A Nodes window 

The Nodes window contains a description of the available nodes in domain that you are 
analyzing, including NEURON IDs, ID string and location, subnet and node numbers and the 
contents of the node self-documentation. 
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Calling the “Scan Network” command from the “Analyzer” menu will automatically open the 
Nodes window. 

Report The “Report” command causes the “Report” window to appear, showing information gener-
ated through the “Consistency Report” command previously. If this command was not yet 
executed the window will remain empty. 

 

Figure 31: A Report window 

The Report window contains status information on the NEURON Chips in the domain that 
you are analyzing and status on the network variables in the network. Both of these parts of 
the information are optionally displayed, depending on the options chosen when generating 
the report. See the “Consistency Report” command in the “View” menu for more details. 
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Toolbar The “Toolbar” command toggles the toolbar on and off. The toolbar is located immediately 
below the menu bar and offers short cuts for the most used commands of Analyzer in the 
form of buttons. 

Buttons that can be selected are shown in white. When the command cannot be executed or 
does not have a meaning in the current context its color is Grey and nothing happens when 
clicking it. 

Below is a list of buttons available on the toolbar together with the command names that 
they are associated with. For detailed information on these functions, we refer to the manual 
entries for each of these commands. 

 

Figure 32: The toolbar 

 New Recording (clears Analyzer buffer first) 

 Stop Recording 

 Delete Packets 

 Get 100 Packets 

 Get until Trigger 

 Next Page 

 Prev Page 

 Show Trigger 

 Activate Filters 

 Deactivate Filters 

 Scan Network 

Status Bar The “Status Bar” command toggles the status bar on and off. The status bar is shown on the 
bottom of the active window and displays on the left side additional menu information. In its 
center the number of packets in the Analyzer’s buffer is displayed. On the right hand side 
information on currently recorded packets per second is given. 
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5.2.4 The View Menu 

The “View” menu contains commands which allow you to control the representation of the 
shown information on the screen. Also, a consistency report can be made and shown, on the 
basis of a network description that was made earlier. 

 

Figure 33: The View menu in its pulled-down state. 

Message 
Addr. 

The “Message Address” command will show the Message Address part of the displayed 
packets information in the Packets window (see figure 34 below). When Message Address 
view is active, the command name is ticked in the menu. 

The Message Address view is only valid in the Packets window and may be combined with 
Message Data and/or Hexadecimal display options. 

By default, the Message Address view is switched on when opening a file. 

Message Addr. Message  Data Hexadecimal

Standard Info

 

Figure 34: Display option of the View menu  

Message Data The “Message Data” command will show the Message Data part of the displayed packets 
information in the Packets window (see figure 34 above). When Message Data view is active, 
the command name is ticked in the menu. 

The Message Data view is only valid in the Packets window and may be combined with 
Message Type and/or Hexadecimal display options. 

By default, the Message Data view is switched on when opening a file. 
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Hexadecimal The “Hexadecimal” command will show the data of the displayed packets in hexadecimal 
notation (see figure 34 above). When Hexadecimal view is active, the command name is 
ticked in the menu. 

The “Hexadecimal” view is only valid in the Packets window and may be combined with 
Message Address and/or Message Data display options. 

By default, the Hexadecimal view is switched off when opening a file. 

Delete 
Packets 

The “Delete Packets” command causes all packets displayed in the active Packets window to 
be deleted. This command does not affect the packets that are still remaining in the packet 
buffer of the Analyzer nor those already saved to file. 

  This command can also be called through the corresponding button in the toolbar. 

Next Page The “Next Page” command will display the next page of the packets window. If a next page 
is not available the command is disabled. 

Packets window pages are not related to printable pages but to displayable pages inside the 
Windows system. The windows used only permit up to 64K possible positions within the 
displayed information set, due to limitations set on the positioning of the scroll box on the 
right-hand side of the window. 

When all packets do not fit into the same window anymore a new window is opened as a 
next page.  

  The “Next Page” command is also available as a button in the toolbar, indicating an arrow 
pointing down.  

The command can also be issued using the keyboards “PageDn” key. 

Prev Page The “Prev Page” command will display the previous page of the packets window. If a previ-
ous page is not available, the menu is disabled. 

The pages are not related to printable pages, but to displayable pages inside the Windows 
system. The windows used only permit up to 64K possible positions within the displayed 
information set, due to limitations set on the positioning of the scroll box on the right-hand 
side of the window. 

  The “Prev Page” command is also available as a button in the toolbar, indicating an arrow 
pointing up.  

The command can also be issued using the keyboards “PageUp” key. 

Show Trigger The “Show Trigger” command causes the active window to scroll to the page and position 
where the trigger packet is located. The trigger packet is selected (highlighted with a blue 
background). If no trigger was read in from the Analyzer’s packet buffer yet this command is 
disabled. 

  The “Show Trigger” command is also available in the form of a button on the toolbar. 

08/31./05  page 45 



 Easylon Analyzer 

Show 
Selection 

The “Show Selection” command causes the active packet window to scroll to make a previ-
ously selected message visible. The selection may have been made by hand or by executing a 
find command. This command is useful when looking at the wider context of a certain mes-
sage before investigating the message further: when scrolling away from the packet it does 
not need to be searched again if no other selection has been made since then. 

Returning to a previous selection does not function if a Page-related command (Next Page or 
Prev Page) has been executed, since these commands have as a side-effect that either the first 
or the last packet of the newly displayed page are selected. The selected packet cannot be on 
a different page from the one currently displayed.  

Since no selection is possible in the Nodes or Report windows, the “Show Selection” com-
mand does not work in these windows. 

Consistency-
Report 

The “Consistency Report” command enables the production of a consistency report between 
the currently attached window and the contents of a NEURON Chips window, which is either 
read in from a file or uploaded from the network previous to executing the “Consistency 
Report” command. 

 

Figure 35: The “Consistency Report” dialog box 

When generating a consistency report, you can choose to have network consistency and/or 
network variable binding checks included. This is done through clicking the appropriate 
check boxes in the dialog box. By default, both checks are included. 

If network variables are not bound, nodes are not available etc., the consistency report show 
this in normal readable text. The report is generated through the Analyzer’s NEURON Chip, 
which is capable of generating directed messages to all other NEURON Chips on the same 
domain, requesting the status of network variables and internal NEURON Chip states to be 
reported to it. 

Clear Report The “Clear Report” command causes the existing Report window to be cleared. The contents 
of this window will never be saved, since the consistency report is the result of an analysis on 
the basis of network information. A new consistency report can be generated from informa-
tion uploaded from the network or stored with the “Save” command at any time. 
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5.2.5 The Analyzer Menu 

The commands in the “Analyzer” menu are divided into four functional groups, which are all 
related to the Easylon Analyzer’s hardware. 

 

Figure 36: The Analyzer menu in its pulled-down state. 

Get 100 
Packets 

The “Get 100 Packets” command causes the next 100 packets to be collected from the 
Analyzer hardware, i.e. the PC receives the next 100 packets that are stored in the packet 
buffer of the Analyzer. Note that there is no selection of packets: the first 100 packets avail-
able in the Analyzer’s packet buffer are read in. Reading packets causes the number of re-
maining packets in the packet buffer to decrease, as is visible in the middle of the status bar. 

  The command is available through a button on the toolbar. 

NOTE All “Get…” commands can be used while recording continues. 

Get all 
Packets 

The “Get all Packets” command causes all remaining packets in the Analyzer’s packet buffer 
to be transferred to the PC. This causes the packet buffer to become empty. 

If the packet buffer was completely filled before new packets have been read into the PC, a 
hiatus in the listed packets appears. Since there is no way of keeping track of the number of 
skipped packets, numbering of the packets in the window continues where it was. A possible 
hiatus in the shown packets is indicated as a red dotted line. 

Get until 
Trigger 

The “Get until Trigger” command causes all packets to be read in up to and including the 
last recorded trigger packet. If no trigger packet was yet recorded, this command behaves 
like the “Get all Packets” command. Trigger packets are set in the “Filter” menu and allow 
control of the packet buffer in the Analyzer: if a certain packet type is associated with the 
trigger command, the Analyzer will either stop recording immediately messages after the 
trigger packet arrives or after a specified number of packets have arrived following this trig-
ger. Additionally, the trigger function can be set to accept several occurrences of the trigger 
type packet before terminating recording.  

In the Packet window a trigger packet is marked with a “T” in front of the sequence num-
ber. 

  The command is available through a button in the toolbar. 
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Figure 37: Packet window with trigger 

See the “Filter Group” menu for explanation about setting a trigger and determining the 
number of packets to be recorded after the trigger has occurred. See the Tutorial section in 
the User Manual for more explanation on how to use combined filters and triggers in analyz-
ing the status of the network. 

Get until Find The “Get until Find” command causes a all packets to be read in from the Analyzer’s packet 
buffer until a packet arrives which is previously defined in the “Find” command of the “Edit” 
menu. 

You can also choose this command by typing <Alt-G>. 

Start 
Recording 

The “Start Recording” command tells the Analyzer to start recording packets from the net-
work into its packet buffer. If the Analyzer was already recording, this command has no 
effect. 

New 
Recording 

The “New Recording” command causes the Analyzer to delete the contents of its packet 
buffer and restart recording packets from the network. Note that this command does not 
change the contents of the visible window. If the Status Bar is visible the number of recorded 
packets starts increasing (unless no traffic occurs on the domain or all occurring packets are 
filtered out by the activated filter group). After new packets have arrived, these can be read 
into the PC using one of the various “Get …” commands from this “Analyzer” menu. 

  You can also choose this command through clicking the button in the toolbar. 
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NOTE The buffer contents is cleared before recording starts 

Stop 
Recording 

The “Stop Recording” command causes the Analyzer to stop collecting packets into its 
packet buffer. 

  
You can also choose this command through the button in the toolbar. 
 
 

Transaction 
Analysis 

Selecting “Transaction Analysis“ will clear the packet buffer and start recording using a 
special filter. This filter is used to record erroneous transactions. Only the last two retries of a 
lost transaction are stored. If the packet buffer stays empty, no transaction error has been 
detected. 

The "Get packets" command is used to show the result of the transaction analysis in the 
Packets Window. 

 

Figure 38: Packets window of Transaction Analysis 

The "Stop recording" command stops the transaction analysis, but the transaction error filter 
is still activated. To clear this filter, the "Deactivate filters" command must be used. 

Scan Network The “Scan Network” command allows a network description to be uploaded, either as a 
complete new scan or as an extension of a previously saved (and currently opened) network 
scan. 

Choosing this command makes a dialog box appear, in which options for the scan can be set: 
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Figure 39: Scan Network dialog box  

Scanning of all nodes of a domain can take quite a while if the domain has a large number of 
nodes. If you want to scan the network for possibly added nodes (e.g. when you found some 
nodes were missing in a first scan, and you found that they were not powered on yet, you 
want to do a new scan after switching the missing nodes on), you do not need to scan the en-
tire network. Choosing the “Load unknown Nodes only” can save a lot of time. 

During the network scan the dialog box shows the progress: the total number of nodes found 
and an index counting the number of nodes already scanned. The total number of nodes in 
the current domain is determined first; after this each single node is addressed for its network 
variables and further internal status information. All information is stored in the temporary 
database on the PC for further use by the Analyzer program. 

  You can also choose this command by clicking the corresponding button in the toolbar. 
 

Analyzer 
Node 

The “Analyzer Node” command allows controlling the network-related settings of the 
Analyzer’s NEURON Chip, i.e. its subnet and node numbers and the domain to which the 
Analyzer belongs. You can use the pop-up menu next to the domain field to choose from the 
available domain names. If no network scan has yet been done this list will be empty. The 
default domain to which the Analyzer belongs as a network node is the Null-Domain. 

 

Figure 40: The “Analyzer Node Parameter” dialog box 

The menu allows setting the subnet and node IDs of the Analyzer. Make sure the sub-
net/node ID that you indicate is not yet used in the domain to be analyzed, since this will 
make any node with the same subnet/node ID invisible to the Analyzer. The safest and easi-
est method to avoid this problem is to give the Analyzer a subnet ID which is not used by 
any of the nodes in the domain that you want to analyze. 
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5.2.6 The Filter Menu 

The commands in the “Filter” menu allow definition and activating of filters and triggers. 
These determine which packets are recorded by the Easylon Analyzer hardware and which are 
ignored. 

 

Figure 41: The Filter menu in its pulled-down state. 

Activate 
Filters 

The “Activate Filters” command causes the previously defined filter group to be activated. 
Whenever the filter group has been changed or any of the filters have been modified, the 
filters have to be explicitly activated before newly added or modified filters can take effect in 
the Analyzer. 

  Activating the filters can also be done by clicking the appropriate button on the toolbar. 
Before you can activate filters you have to select your current filters first with the “Filter 
Group” command. The “Activate Filters” command is enabled only after doing so. Acti-
vating filters can also be done directly from the “Filter Group” dialog box. 

Deactivate 
Filters 

The “Deactivate Filters” command causes the defined filter group to become deactivated; the 
Analyzer will from this moment on record all packets. 

  Deactivating all filters can also be done by clicking the appropriate button on the toolbar. 
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Filter Group The “Filter Group” command allows setting of filters, i.e. selecting filter descriptions which 
have been made previously through the “New NV-Filter” or “New Address-Filter” com-
mands and associating these to actual filtering conditions. In the filter descriptions you spec-
ify a certain type of packet, on the basis of sender and addressed nodes identification, message 
type or parts of the message contents. See the corresponding command descriptions for more 
details on the filter definitions. 

 

Figure 42: Filter Group Definition dialog box 

When first opening the “Filter Group” dialog box, the list of filters in the group is empty. 
You add filters, conditions and associated commands to the list by clicking the “Add” button. 
This shows the list of available filters, according to the previously defined and named filters. 

After you have added a filter you need to define a condition (equal to, not equal to, …) for 
the comparisons that are made between each message packet and the filter specification by 
the Easylon Analyzer hardware when listening in on the network communications. You do 
this through the lower pull-down menu: click the arrow and select the desired condition. 

Finally you have to define an action to be taken by the Analyzer when an actual packet 
matches the filter and assigned condition. This action can be to show the packet, to ignore it 
or to trigger on it. Use the middle pull-down menu for these commands. If you choose 
“show”, all packets matching the filter and assigned condition will be recorded in the Ana-
lyzer’s packet buffer and can be made visible through one of the “Get…” commands. 

 

Figure 43: The command menu inside the Filter Group dialog box 
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When you choose to ignore the specified type of packets any packets matching the filter are 
ignored, regardless of whether they fit a type description for a filter associated with the 
“show” command. With combinations of filter descriptions associated to the “show” and “ig-
nore” commands it is possible to define a hybrid type of set of packets to be recorded by the 
Analyzer. For example, you might want to record all packets sent to node number 4 except 
when coming from node number 0. To get this effect, you define a filter matching all packets 
with destination node 4 and associate the “show” command to it; also, you define a filter 
matching all packets initiated from node 0 and associate the “ignore” command to it. 

The “Trigger” command causes the Analyzer to stop recording when a packet matching the 
filter used as trigger has been found (you can indicate a later occurrence of this trigger packet 
as well). A number of messages to be recorded after the trigger event can be specified in the 
Post Trigger box. This option is used when you want to investigate a specific packet occur-
rence (in most cases you will be looking for an error condition which leads to subsequent er-
rors). Using the trigger command, you can size down the number of recorded and subse-
quently shown packets to concentrate on a certain condition or status appearing in the net-
work. The “Get until Trigger” command helps to quickly find the trigger event. 

Also (and perhaps a more important use), you may use triggers to detect some seldom ap-
pearing packets in a domain and freeze it and the preceding and following messages in the 
packet buffer. So you are able to make investigations to the point, especially if you use the 
“occurrence” and Post Trigger settings with deliberation. The Analyzer can observe the net-
work for hours (even without a PC connected) and will keep the interesting log of the net-
work traffic —the buffer contents will not be overwritten after the trigger event. Effects of 
the trigger event can be studied (e.g. when a network variable with a too high value is 
propagated through the network, you need to see how the other nodes respond to the error 
condition).  

 

  

The selected filters with their associated conditions and commands are listed. Only these 
filters will be used by the Analyzer. They can be activated from within this Filter Group 
dialog box or through the “Activate Filters” command or corresponding button. 
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New NV 
Filter 

The “New NV Filter” command enables the definition of a filter through the use of network 
variables. This menu is only available if a scan of the network has been made previously or if 
a network description has been read in from a file. Note that in the latter case you must be 
certain that the network description in the file matches the actual status of your network. It 
might be useful to look at the consistency report for this. 

The New NV Filter dialog box allows you to browse through all known nodes in the current 
domain and subsequently indicate a certain network variable as the base definition of a filter. 

 

Figure 44: New NV Filter dialog box 

On the left a list of available nodes is displayed. Selecting one of these nodes makes a list of 
its network variables appear on the right, of which you can select one. If you want to define 
more than one filter, you should name each filter individually; if you do not name the filter it 
will appear in the filter description list of the “Filter Group” command as “Untitled”. 

When selecting a network variable its current value is queried from the network and dis-
played in the “New NV Filter” dialog box. You can make the filter description more specific 
by entering a “Match Value”: in that case only messages with the selected NV having this 
value will be identified by the Easylon Analyzer and are then handled according to the set-
tings in the Filter Group dialog box. This option is useful when trying to detect a specific er-
ror condition without wanting to read in all messages surrounding it. 
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New Address 
Filter 

The “New Address Filter” command enables the definition of a filter packet type on the basis 
of network addresses rather than using the network variables. You want to do this when 
checking all messages travelling to one specific node or a group of nodes or all packets 
generated by a single node.  

 

Figure 45: The “New Address Filter” dialog box 

The dialog box contains a number of pop-up menus hidden behind the buttons to the right 
of each option box. Clicking the button enables you to choose one of the available options.  

Selecting a sender node (Source Address) is always specific: you indicate the subnet and node 
ID and the ProgID. 

You can also specify a filter on the basis of addressed nodes (Destination Address). In this op-
tion, you can choose subnets, specific nodes or groups (if these have been defined). The se-
lected “Address Format” influences the possible entries for the Destination Address. Possible 
choices are “subnet/node”, “broadcast” or “group”. 

By combining the sender and addressed node specifications, you can narrow down the filter 
description to only cover traffic between two individual nodes. 

Note that you must name the address filter if you want to work with multiple filters: you 
need to be able to specify the correct filter descriptions by name in the “Filter Group” com-
mand. Not naming a filter causes it to appear as “Untitled” in the filter menu of the “Filter 
Group” dialog box. 
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Modify Filter The “Modify Filter” command allows changing previously made filter descriptions. This 
command causes a dialog box to appear through which you can choose the filter to be 
modified. Select the filter you want to modify and click “OK”. This takes you into the same 
dialog box as when choosing either “New NV Filter” or “New Address Filter”. The only 
difference is that the name of the filter has been filled in the appropriate text box. You can-
not change the name of the filter in this case. 

 

Figure 46: The “Modify Filter” dialog box 

Delete Filter The “Delete Filter” command allows deleting a filter. This effectively removes the filter de-
scription, i.e. when calling the “Filter Group” command to install a new filter the deleted fil-
ter will not appear in the list of available filters anymore.  

If you want to temporarily disable a filter, you do not want to delete it and rewrite the filter 
description later on: instead, you will want to use the “Filter Group” command to remove the 
filter from the list of used filters.  

For selection of the filter to be deleted the “Choose Filter” dialog box is offered. 
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5.2.7 The Info Menu 

The “Info” menu contains commands that provide status information on the network, its 
nodes, the network variables and the Easylon Analyzer hardware, the Analyzer. Some of the 
commands allow changes to be made to the values of some settings and variables (notably the 
“NEURON Status” and the “NV-Browser” commands). 

 

Figure 47: The Info menu in its pulled-down state 

Node Info The “Node Info” command enables reading and setting the status of individual nodes in the 
domain that is being analyzed. 

 

Figure 48: The “Node Information” dialog box 

The available nodes are listed to the left; selecting one of them will make its status visible to 
the right and some more information below the nodes list. If you have defined the “Location” 
field for the node, this will show in the appropriate text box. This location can be changed in 
the “Node Info” dialog box: type the new location in this text box and choose “Write Loca-
tion” from the “Commands…” pop-up menu. The other available commands are shown be-
low: 
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Figure 49: The “Commands” list in the Node Information dialog box 

“Reset”  Causes a software reset to be executed on the selected node. 

“Wink” Causes a wink signal to be sent to the selected node. The way in which a 
node reacts on receiving a wink signal is hardware and application-depend-
ent. 

“Clear Status” Causes the status of the selected node’s NEURON Chip to be cleared, i.e. the 
runtime-dependent status indicators are reset. 

“Show Status” Causes the current NEURON Chip status to be read in and displayed in the 
dialog box. This command is also executed each time a node is selected from 
the list of available nodes. 

“Write Location” Causes the location you have typed into the “Location” text box to be 
written into the NEURON Chip. 

“Set Online” and "Set Offline" Cause the NEURON Chip to be set online or offline. 

“clear F1FE” Causes the EEPROM checksum of the NEURON Chip to be cleared. s 
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NV Browser The “NV Browser” command allows reading and changing the status of network variables in 
the domain to which the Analyzer is connected. Since this implies information about the 
network the NV is available only after scanning the network. 

When calling the NV the following dialog box appears: 

 

Figure 50: The “NV Browser” dialog box 

To investigate the status of network variables you need to first select a node. The nodes are 
listed by their self-documented names in the “Nodes” box to the left. Clicking one of the 
available nodes makes the NVs of that node appear to the right. 

Choosing one of the NVs causes its current value to be read from the NEURON Chip and to 
be displayed in the “Value” box. To the left its “Input” or “Output” direction is displayed and 
below the length of the NV in bytes. 

If an input variable has been selected, the “Set” button and according input box are activated. 
The format of both the “Value” and the “Set” field depend on the type of network variable. 
The standard network variable types supported by LONWORKS technology are restricted to 
certain values and the “Set” button behaves accordingly: the button is disabled until the 
format matches the prescribed number of digits. 
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Figure 51: Changing the value of a network variable 

When the “Set” button is enabled you can change the value of the network variable accord-
ing to the set value by clicking the button. The NV is updated in the node and the “Value” 
field will display the new status.  

In some cases an input NV cannot be read from the node, although it can still be set. This 
happens in the case of write-only registers in the node’s application, which cannot be read 
back. The “Value” field will show “unknown” in these cases. 

When a group membership applies to the network variable, this group is shown in the corre-
sponding box on the lower left side of the dialog box. 

Clicking “Close” causes the NV Browser window to disappear. Note that clicking “Close” 
does not cause a possible change in the “Set” box to be propagated to the indicated network 
variable before closing the NV Browser. Any change in input variables needs to be done ex-
plicitly by clicking the “Set” button for that variable. 

Domain List The "Domain List" command causes a list of known domains to be displayed. If no domains 
were found on the network that you are analyzing (e.g. when all nodes are in the null-domain 
only), the list remains empty. Otherwise, a list of domain names is shown. 

 

Figure 52: The “Domain List” dialog box 
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Technical The “Technical” command allows investigation of the NEURON Chips in the active domain, 
including all network variables, on a very technical level.  

ATTENTION Since the information given is on a fairly low technical level and modifications can destroy 
applications and hardware past cure it is not advisable to anyone but experts in LONWORKS 
technology to use the information or change the settings in this dialog box. The explanation 
given here is restricted to how to display the various types of information and does not in-
clude an explanation on the meaning of all items. 

 

Figure 53: The “Technical Information” dialog box 

The dialog box opens with a list of available nodes in the top left field. Selecting one of these 
nodes causes its information to become visible in the top right field. You can scroll up and 
down to view parts of the information that are not visible due to the restricted field size. You 
can select lines of information, but it is not possible to change anything here. 

When selecting a node its network variables become visible in the list below the nodes list. 
Selecting one of these network variables causes technical information about that variable to 
be displayed to the right. Again, no information can be changed here. 

The area on the bottom of the dialog box is marked with “Memory” and is the most danger-
ous of the “Technical” command. With the buttons and text fields in this area you can 
change the contents of the NEURON Chip’s memory on the basis of hexadecimal memory 
dumps. Change the address to the location you want to investigate and click “Get” to display 
a number of bytes (in hexadecimal notation) in the “Value” field. The "count" field allows you 
to determine the number of digits displayed in the "value" field. Changing this “Value” field 
and clicking the “Set” button causes the changed value to be written out to the indicated 
location in the selected node’s NEURON Chip.  

ATTENTION Since the program of the NEURON Chip and its configuration (e.g. the communication pa-
rameters and program start address, etc.) are stored in this memory area, you may effectively 
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kill the NEURON Chip by overwriting certain memory contents. This can lead to permanent 
loss of the affected NEURON Chip, since it may not know how to communicate on the net-
work anymore. It is therefore not advisable to anyone but absolute experts to use this feature 
of the Easylon Analyzer. 

About 
Analyzer 

The “About Analyzer” command causes a box to appear displaying information about the 
Easylon Analyzer version (both program and firmware). The box contains a text field indi-
cating the Easylon Analyzer firmware version, which is displayed if the Analyzer is powered 
on and connected.  

 

Figure 54: The “About Easylon Analyzer” box 

Selecting this command will always resume communication from the Analyzer program to 
the Analyzer. If the text “comm_err” is displayed then the communication with the PC can-
not take place due to either the Analyzer not being switched on or the connection with the 
PC not being in working order. The first problem should be easy to detect (no LED is 
blinking on the Analyzer front panel) and solved. The second problem could be in the hard-
ware (connectors not plugged in or cable corrupted) or in the software on the PC (the correct 
serial port not being initialized): make sure the file “LNA.INI” is placed in the Windows 
home directory in order to make the correct serial connection available from within the 
Windows environment. 

NOTE If you correct possible problems (like switching on the Analyzer or plugging in the com-
munication cable to the PC) you must close and re-open the “About Easylon Analyzer” box 
before you can start working. Only after a working connection has been established with the 
Analyzer you can use the functionality of the Easylon Analyzer. 
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6 Appendices 

6.1 Glossary 

Address Filter A type of filter, based on logical addresses of sending and/or addressed 
nodes. An address filter is defined using the “New Address Filter” command 
in the “Filter” menu. 

Analyzer hardware Apart from the software program running on a PC under Windows, impor-
tant functions of the Easylon Analyzer are realized on a hardware device, the 
Analyzer Box.  

Consistency Report A report on the logical consistency of a scanned network domain (NEURON 
Chip addresses and network variable bindings). A consistency report is gen-
erated when choosing the “Consistency-Report” command from the “View” 
menu. 

Filter Definition of certain characteristics of a message packet. Principally the 
Filters apply to address characteristics (Address Filters) or to NV character-
istics (NV Filters). Filters are used to control the recording of packets 
meeting or failing the description given in the filter definition. The appro-
priate conditions and commands for the use of the filters are assigned in the 
-> “Filter Group” command, where as well a selection of the applicable fil-
ters is made from the defined filters list. Filters are described, set and acti-
vated through commands in the “File” menu. 

Filter Group Combination of different filters associated with filtering conditions and 
commands. Only the filters in the Filter Group list are used to control the 
recording of packets into the Analyzer’s buffer. The “Filter Group” is de-
fined through this command in the “Filter” menu.  

Network LONWORKS network to be analyzed with the Easylon Analyzer. Several 
analysis functions of the Easylon Analyzer only apply to the network do-
main to which it is set, although packets from all domain are recorded. 

Nodes window The window in which node information is shown. This window is made vis-
ible when choosing the “Nodes” command from the “View” menu. 

NV A utility allowing investigation and setting of network variables in the ana-
lyzed network domain. This utility is available through the “NV-Browser” 
command in the “Info” menu (only after the network domain has been 
scanned).  

NV Filter A type of filter, based on network variable names. An NV-filter is defined 
using the “New NV Filter” command in the “Filter” menu. 
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Packet buffer A software FIFO implemented in the DRAM of the recorder part of the 
Easylon Analyzer Hardware. Depending on packet size up to 18 000 pack-
ets can be held in the current version. 

Packets window The window in which packet information is shown. This window is made 
visible when choosing the “Packets” command from the “View” menu. 

Analyzer Box High performance LONWORKS node from Gesytec. Apart from the 
NEURON Chip and LONWORKS network interface the Analyzer Box pro-
vide a Motorola 683xx CPU.  

Recorder The part of the Easylon Analyzer hardware which records messages from the 
network into the packet buffer applying the user-defined filters. The re-
corder can be switched on and off through the “Start Recording”, “New Re-
cording” and “Stop Recording” commands from the “Analyzer” menu. 

Report window The window in which a consistency report is shown. This window is dis-
played when choosing the “Report” command from the “View” menu. 

Scanning Scanning a network domain, i.e. using the Easylon Analyzer to request 
information from the network nodes. Scanning a network domain is done 
through choosing the “Scan Network” command from the “Analyzer” 
menu. 

Selection In the Easylon Analyzer software and this manual, a “selection” designates 
the selected single packet in the packets window. Selection of a packet is 
done manually, through clicking on the packet, as an effect of the “Find” 
commands from the “Edit” menu, or as a side-effect of some of the com-
mands in the “View” menu. There is no way of selecting more than one 
single packet. 

Status Bar The bottom part of the Analyzer window, showing comments on selected 
menu items, the number of packets currently recorded in the Analyzer’s 
packet buffer and, while recording, the number of packets per second. The 
status bar is displayed by default, but can be switched off (and on again) 
through the “Status Bar” command in the “View” menu. 

Toolbar A set of buttons displayed immediately below the menu bar of the Easylon 
Analyzer window enabling fast access to a number of often-used commands. 
The toolbar is displayed by default, but can be switched off (and on again) 
through the “Toolbar” command from the “View” menu. 

Trigger A special use of a filter, allowing the recording of messages to stop at occur-
rence of a packet meeting the characteristics of this filter. A specified num-
ber of packets can be recorded after the trigger event. A trigger can be set 
through the “Filter Group” command in the “Filter” menu. 

Uploading See “Scanning”. 
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6.2 List of short-cuts 
Keys Command Menu 

Ctrl + N New File 

Ctrl + O Open File 

Ctrl + S Save File 

Ctrl + P Print File 

Ctrl + F Find Edit 

Ctrl + G Find Next Edit 

Alt + G Get until Find Analyzer 

Alt + F4 Exit File 
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